Плагин позволяет говорить старым клиентам с новыми (новые стим версии начиная приблизительно с 6027 билда).
Это значит что NonSteam теперь спокойно могут общатся с игроками Steam

Для работы необходим Dproto версии не ниже 0.9.356

Особенности:
Перекодирование голосовых пакетов из Speex в SILK и наоборот
Увеличение громкости при перекодировании (sv_voicevolume_speex и sv_voicevolume_silk квары)
Предотвращение флуда голосовыми пакетами (sv_voicefloodms квар, по умолчанию отключён)

Квары в server.cfg:
sv_voicevolume_speex - для увеличения/уменьшения громкости при перекодировании из Speex в SILK (по умолчанию 1.0)
sv_voicevolume_silk - для увеличения/уменьшения громкости при перекодировании из SILK в Speex (по умолчанию 1.0)
sv_voicefloodms - для предотвращения флуда голосовыми пакетами, значение в миллисекундах (например спидхаком, по умолчанию 0 отключено)

Установка:
Зайдите в директорию вашей игры (например valve или cstrike) и скопируйте в эту директорию папку addons из архива
Затем зайдите директорию metamod (обычно это addons/metamod/) и добавьте после dproto в plugins.ini:

Для Windows:
win32 addons\vtc\vtc.dll

Для Linux:
linux addons/vtc/vtc.so

Текущая версия: 80

Известные проблемы:
Плагин запускается, но игроки не могут говорить (кривой liblist.gam).
Чтобы исправить эту проблему, вам нужно закомментировать или удалить эти строчки в liblist.gam:
gamedll "dlls\mp.dll"
gamedll "dlls\hl.dll"
gamedll_linux "dlls/cs_i386.so"
gamedll_linux "dlls/hl_i386.so"
gamedll_linux "dlls/cs.so"


Автор плагина: [email protected]